So lately at work I’ve been tasked with implementing our new VMware vSphere virtualization infrastructure. We’ve been looking forward to getting into the virtualization space for some time now and we were really happy that the decision was made to go with VMware. Not only did we get the software, but I got the hardware that I thought would be necessary to get us started. We ended up purchasing 3 IBM x3650 M2 servers with dual Xeon 5560 procs and 32GB of RAM. Although, I think I short changed the server when it comes to RAM so future servers will have at least 64GB of RAM. The one downside to all of this was that we were hoping to get a NetApp SAN but ended up with a Hitachi USPV, AMS 2500 and ENAS Gateway.

Anyway, the last month or so has been spent downloading and printing out white papers and docs on VMware and NetBackup as I have tried to familiarize myself with everything and how it works. I’ve also had fun setting up VMware’s vCenter Server and playing with clustering, HA and Fault Tolerance. I did run into a couple problems at first with the UEFI of the x3650 M2’s and ESX (see and comments by MCJJJJ). But, after doing research I decided to go with ESXi because it appears that VMware is moving forward with that rather than ESX (see ESXi Chronicles). Nothing major to really hold us up though.

In my testing I’ve been impressed with the functionality and resilience of this product. One of my tests involved running the vCenter Server in a VM and powering off the host that it was running on. A couple minutes later it came back up on the other host in the cluster and chugged right along. Similar tests with VMs were just as successful. It’s nice to run tests and actually have them work as advertised. 🙂 Also, having them clustered makes it really easy to update the hosts for whatever reason.

Fault Tolerance is another cool feature but at this point we really don’t have anything that merits the resource overhead associated with running it or that needs that kind of reliability.

Then there’s the backup solution. We weren’t really sure what to do there but since we already have NetBackup deployed, setting up a VCB (VMware Consolidated Backup) proxy seemed like the best solution for now. More docs and reading for that one. 🙂

Finally I got everything setup and it appears to be working. I am having some problems with the backups though, but this mainly appears to be with snapshotting SQL servers. One is on Windows 2000 Server and the other is on Windows Server 2003. I’m looking into it now but I think it’s because it’s not quiescing the server correctly before it takes a snapshot. I know the best way would probably be to put an agent on the actual guest but that costs more money and since the data is actually getting backed up to disk on that server through SQL jobs I think we’re fairly safe for now…I hope. Like I said, I’m still looking into this. However, as far as backups of the other servers go, it’s working great. I love how much faster it is and that we have the ability to restore individual files from the snapshot if we need to.

Overall, I’m really satisfied with the product and what it does.  It hasn’t been a real pain to get setup either (unlike some of the Microsoft stuff I’ve worked with). It works, and that’s nice.